News

Microsoft Suggests Blocking .NET Framework 4.6.1 for Exchange Server Users

.NET Framework 4.6.1 should be avoided for the near future for those enterprises running Exchange Server.

It shouldn't be installed right now because no Exchange Server version supports it yet, Microsoft's Exchange team warned, in a blog post yesterday. The supported versions of .NET Framework are shown in Microsoft's Exchange Server supportability table, which looks like this:

[Click on image for larger view.] Exchange Server and supported .NET Framework versions. Source: Microsoft TechNet article.

If .NET Framework 4.6.1 gets installed, it can cause computing environments with Exchange Server 2013 to have unexpected mailbox quarantines upon dismount, among other problems, as described in this Microsoft support article.

Microsoft's Exchange team is recommending that organizations running Exchange Server delay the .NET Framework 4.6.1 update, which is arriving now via the Windows Update service. The registry changes needed to block its arrival are described in this support article.

Update 2/12/16: Jeff Guillet, a Microsoft Certified Solutions Master and Exchange MVP explained that .NET Framework 4.6.1 should be blocked for Skype for Business Server products, too. But getting .NET Framework 4.6.1 off your system, instead of rebuilding it, involves a number of careful steps. He outlines an approach to take in this blog post.

The need to block any new .NET Framework versions is somewhat peculiar because Microsoft accelerated the migration timeline for organizations. It set a general date of Jan. 12, 2016 for organizations to move to .NET Framework 4.5.2, for instance, in order to stay on a supported framework.

Exchange Server 2013 Service Pack 1 is currently supported with .NET Framework 4.5.2, but not by the more current framework releases.

About the Author

Kurt Mackie is senior news producer for the 1105 Enterprise Computing Group.

comments powered by Disqus

SharePoint Watch

Sign up for our newsletter.

I agree to this site's Privacy Policy.